Auteur Sujet: Ram libre et Swap utilisée...  (Lu 3563 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne Tete de Lard

  • Débutant
  • *
  • Messages: 11
    • {TÊTE DE LARD}{CONCEPT STORE}
Ram libre et Swap utilisée...
« le: 02 Novembre 2008 à 14:23:49 »
Bonjour a tous j'ai un souci et après des semaines de recherches, de test, de paufinage de config, de debug et de monitoring je n'en parviens pas a bout.

Afin que vous compreniez voici le top de mon top en utilisation "normale" du serveur
(qui heberge un site internet, donc apache 2 + php5 + mysql + postfix + amavis + mrtg)

top - 13:50:22 up 22:24,  1 user,  load average: 0.02, 0.01, 0.00
Tasks:  68 total,   1 running,  67 sleeping,   0 stopped,   0 zombie
Cpu(s):  0.3%us,  0.7%sy,  0.0%ni, 90.9%id,  8.1%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:    512000k total,   133804k used,   378196k free,        0k buffers
Swap:  1488000k total,  1105180k used,   382820k free,        0k cached

Comme vous le constatez il ya plein de ram libre et pourtant il utilise les 3/4 du swap dispo et je ne crois pas avoir jamais eu rien dans les buffers ou en cached.

Et d'apres tout ce que j'ai lu cela n'est pas normal du tout...
Surtout qu'aux "heures de pointes", c'est a dire dès que j'ai disons plus de 10 personnes en même temps sur le site, le swap se rempli , le serveur ralenti a l'extreme et des messages d'erreur d'allocation de mémoire etc apparaissent dans tout les logs

Le proc n'est quasiment pas utilisé (sauf jeudi ou il m'a fait un pic a 88% pendant 20 minutes pour une raison totalement inconnue)

Le reboots n'y changent rien...

Et je suis paumée... Une p'tite piste ?

Hors ligne shaitan

  • Habitué
  • **
  • Messages: 142
    • Passion Xbmc
Re : Ram libre et Swap utilisée...
« Réponse #1 le: 02 Novembre 2008 à 23:59:41 »
Salut,

Est ce que tu as tenté de n'activer les services que l'un après l'autre pour éventuellement trouver le coupable ? Ou de les désactiver ?
cl1-sq4 , serveur de fichiers 4 et mon Fai est Free.
Et mon site est là: http://passion-xbmc.org/forum/
Quand à mes requêtes elles sont optimisées.

Hors ligne Tete de Lard

  • Débutant
  • *
  • Messages: 11
    • {TÊTE DE LARD}{CONCEPT STORE}
Re : Ram libre et Swap utilisée...
« Réponse #2 le: 03 Novembre 2008 à 00:24:42 »
hé bien oui, mais ils sont tous coupables en quelque sorte, a plus ou moins grande echelle...
en arrêtant postfix je "gagne" 100 M de swap et 10 de ram
en arrêtant apache 2 je récupère un gros bout de tout : la ram descend a 27M utilisée et la swap a 280M
Donc je dirai que c'est lui le fautif...
Mysql me ait gagner un peu de ram et 120M de swap
et bind c'est négligeable,
mais une fois tout cela stoppé il reste encore 120 M de swap, et toujours rien dans les buffers ou le cache.
(est ce a ce moment la, une fois que tout est arreté que je dois tenter un swappoff swappon ?)

M'enfin je redémarre tout l'bouzin, parce que j'en ai besoin quand même, la ram monte a 68M et le swap a 450M, puis je consulte ma page mrtg et la zou le serveur prend 350M de swap !
Donc apache ok, mais ça ne m'explique pas pourquoi mon serveur swap autant au lieu de consommer la ram dispo.

Il doit y avoir une config de quelque chose quelque part qui l'empêche de se comporter comme tout serveur normalement constitué...