Auteur Sujet: mise à jour PHP version?  (Lu 2941 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne roelof berkepeis

  • Débutant
  • *
  • Messages: 1
    • VimeXcom Figeac
mise à jour PHP version?
« le: 07 Septembre 2011 à 12:23:37 »
-- (Google) traduction ci-dessous --

We are using the Joomla CMS with the Akeeba Backup extension. After we did a backup, its log file states : "Your server has a buggy PHP version which produces inverted CRC32 values. Attempting a workaround. ZIP files may appear as corrupt." While searching for a cause of this, an Abeeka forum entry states the following :

"When I mention in the requirements page that Akeeba Backup required PHP 5.2.6+ I really mean it. PHP 5.2.4 and 5.2.5 were extremely buggy and don't work properly. Moreover, the latest PHP 5.2 version is 5.2.17, released two months ago. Your release is ancient, contains a ton of vulnerabilities and should not be used on a live site. Not to mention that PHP 5.2 reached end of life two months ago. Maybe you should seriously consider a PHP upgrade on your server?"

Using the standard PHP command phpinfo() I see that your PHP version is 5.2.6-1+lenny13. So I guess you should upgrade ..!?

---

Nous utilisons le CMS Joomla avec l'extension de sauvegarde Akeeba. Après nous avons fait une sauvegarde, de ses Etats fichier journal: "Votre serveur a une version de PHP poussette qui produit des valeurs inversées CRC32 Tenter une solution de contournement des fichiers ZIP peuvent apparaître comme des corrompus..." Alors que la recherche d'une cause de cela, une entrée Abeeka Forum stipule ce qui suit:

«Quand je mentionne dans la page des exigences qui sauvegarde Akeeba nécessaire PHP 5.2.6 +, je le pense vraiment. PHP 5.2.4 et 5.2.5 étaient extrêmement buggé et ne fonctionnent pas correctement. Par ailleurs, la dernière version de PHP 5.2 est de 5,2. 17, publié il ya deux mois. Votre communiqué est ancienne, contient une tonne de vulnérabilités et ne doit pas être utilisé sur un site en direct. Sans compter que PHP 5.2 a atteint la fin de vie il ya deux mois. peut-être que vous devriez sérieusement envisager une mise à jour de PHP sur les votre serveur? "

En utilisant la commande standard de PHP phpinfo () Je vois que votre version de PHP est 5.2.6-1 + lenny13. Donc je suppose que vous devez mettre à jour ..!?

Hors ligne Jean.

  • Administrateur
  • Débutant
  • *****
  • Messages: 65
Re : mise à jour PHP version?
« Réponse #1 le: 07 Septembre 2011 à 15:23:04 »
La version de PHP sur Prémium est la version packagée sur Debian Lenny et possède donc des mises à jour de sécurité fréquentes.

D'après le message en question il faut au moins la version 5.2.6, c'est la version justement installée ; si vous le désirez, nous pouvons mettre à jour votre Prémium de Debian Lenny (5.0) à Debian Squeeze (6.0), cela permet d'avoir le PHP en version 5.3, cette opération est par contre irréversible.


ps: il faut nous ouvrir un ticket d'intervention depuis le panel pour une telle demande.