Auteur Sujet: Erreur 403 Forbidden Avec Ma Config Php Sous Linux  (Lu 7615 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne anderson2

  • Connaisseur
  • ***
  • Messages: 426
    • http://www.rpg-maker.org
Erreur 403 Forbidden Avec Ma Config Php Sous Linux
« le: 14 avril 2003 à 19:40:13 »
voila, cool, j'ai trouvé le bon IDE sous Linux, grace a vous  :D, mais maintenant petite bourde avec Apache: J'ai voulut changé le dossier des fichiers www/, pour le mettre dans /home et ainsi eviter a avoir a me logger en root a chaque modif' d'un fichier (...)
Bon, j'ai changé dans /etc/httpd/conf/httpd.conf:

DocumentRoot /var/www/html
par:

DocumentRoot /home/cedric/www/html
Cool, sauf que maintenant, j'ai le droit a:

Forbidden

 You don't have permission to access / on this server.

 :blink:, quelqu'un a un idée? merci d'avance

@+

Hors ligne Yann

  • Débutant
  • *
  • Messages: 40
    • http://www.bwc-clan.com
Erreur 403 Forbidden Avec Ma Config Php Sous Linux
« Réponse #1 le: 14 avril 2003 à 19:47:01 »
tu dois donner les droits d'accès au process apache au répertoire en question
à savoir /home/cedric/www/html...
T'as des explorateurs de fichiers graphiques qui permettent de faire ça facilement, si bien sûr le process apache est lancé avec le compte apache et pas un autre :) ça tu peux le vérifier avec la commande ps en mode console (ps -aux par exemple devrait te donner le nom du propriétaire du process httpd)
« Modifié: 14 avril 2003 à 19:48:17 par Yann »

Hors ligne anderson2

  • Connaisseur
  • ***
  • Messages: 426
    • http://www.rpg-maker.org
Erreur 403 Forbidden Avec Ma Config Php Sous Linux
« Réponse #2 le: 14 avril 2003 à 20:01:34 »
arf, excuse moi, mais je n'est pas tout compris (excuse moi de mon ignorance, ca fait qu'une semaine que je suis sous linux).

En console, j'ai tapé ps -aux, ok, ca me donne pour [libhttpd.ep] => user apache, et pour httpd -f /etc/httpd/co => user root. C'est bien ca que je dois chercher?

Et comment faire pour donner au process apache les droits d'acces au dossier?

Merci de votre future aide, et de votre patience avec un débutant linux  :rolleyes:

@+

Hors ligne Yann

  • Débutant
  • *
  • Messages: 40
    • http://www.bwc-clan.com
Erreur 403 Forbidden Avec Ma Config Php Sous Linux
« Réponse #3 le: 14 avril 2003 à 20:12:29 »
je pense qu'en donnant les droits au user apache sur le répertoire ça devrait passer (faut aussi donner les droits à tous les fichiers /sous-réepertoires de ce répertoire au compte apache). Pour ce faire, tu utilises quoi comme environnement graphique?

Hors ligne kevin

  • vip
  • Habitué
  • **
  • Messages: 228
Erreur 403 Forbidden Avec Ma Config Php Sous Linux
« Réponse #4 le: 14 avril 2003 à 20:16:46 »
http://www.e-gineer.com/instructions/

regarde ce site c plutot bien expliqué :D
print map{chr(2.875*$_**4-32.25*$_**3+117.13*$_**2-142.75*$_+130)}(1..5)

Hors ligne anderson2

  • Connaisseur
  • ***
  • Messages: 426
    • http://www.rpg-maker.org
Erreur 403 Forbidden Avec Ma Config Php Sous Linux
« Réponse #5 le: 14 avril 2003 à 20:17:14 »
slt,
j'utilise KDE 3.1, et Konqueror comme "Navigateur".

merci à toi.

@+

Hors ligne Yann

  • Débutant
  • *
  • Messages: 40
    • http://www.bwc-clan.com
Erreur 403 Forbidden Avec Ma Config Php Sous Linux
« Réponse #6 le: 14 avril 2003 à 20:21:18 »
je suis pas un pro non plus mais j'essaie de te doner les indications de mémoire, là je suis pas sous linux.. donc normalement tu as un endroit dans le menu démarrer qui ressemble fortement à celui de windows, et tu dois avoir un endroit qui s'appele je sais plus dans quelle rubrique gestionnaire de fichiers...là y'a plusieurs programmes, et normalement tous permettent plus ou mins facilement de changer les droits d'accès des fichiers/répertoires... je fais ça de mémoire désolé, j'y suis plus tous les jours sous linux :)

Hors ligne anderson2

  • Connaisseur
  • ***
  • Messages: 426
    • http://www.rpg-maker.org
Erreur 403 Forbidden Avec Ma Config Php Sous Linux
« Réponse #7 le: 14 avril 2003 à 20:27:26 »
ok, merci a toi, la j'ai pas le temps, j'ai cherché vite fait (en vain), je regarde en détail demain. Si quelqu'un aurait le nom du programme ou la manip, ca m'arrangerais aussi.

merci d'avance...

@+


 

Hors ligne achil

  • Habitué
  • **
  • Messages: 178
Erreur 403 Forbidden Avec Ma Config Php Sous Linux
« Réponse #8 le: 14 avril 2003 à 20:28:31 »
le forbidden apparait dans deux cas:
-Le rep n'est pas dans la configuration d'apache comme etant regardable, pour indiquer a apache qu'il est autorise a regarder dans le repertoire home je te conseil la section suivante:
<Directory /home>
    AllowOverride All
    Options Indexes FollowSymLinks Includes MultiViews
    Order allow,deny
    Allow from all
</Directory>
-Apache, et plus precisement httpd doit avoir les droits sur l'arborescence UNIX de voir ton rep, en effet apache est un programme qui tourne sur la machine, et comme tout programme qui est la plus part du temps non root, il ne peut aller regarder tout les fichiers si il n'est pas autorise, en fait apache ce lance sous un utilisateur UNIX et de ce fait il possède les droits de cette utilisateur. Sur beaucoup de distribution il est lance entant que nobody, ce qui plustot pas mal, il faut donc rajouter sur le repertoire que tu veux voir les droits a apache de le regarder. il te suffira de mettre les droits de lecture pour un fichier, et lecture et execution pour les repertoires; en gros un chmod -R o=rx /home/tonuser donne a apache la possibilite de voir tout ton rep.



NB: le terme DOSSIER est une connerie invente par Microsoft pour l'OS oriente secretaire: Windows, le terme adequat est REPERTOIRE.

Hors ligne Bouki

  • Habitué
  • **
  • Messages: 244
    • http://www.scripetudes.net
Erreur 403 Forbidden Avec Ma Config Php Sous Linux
« Réponse #9 le: 15 avril 2003 à 02:11:29 »
c'est hyper simple puisque t'es sous mandrake,
tu sélectionnes le dossier/fichier sous konqueror et puis tu fais clique droit > propriétés et tu le fais apartenir au groupe apache le dossier (je suis pas sous linux en ce moment mais je me rapelle que c'est ça sous mandrake)
Bouki
oO .:: [ Mage développeur Bouki ] ::. Oo


Hors ligne anderson2

  • Connaisseur
  • ***
  • Messages: 426
    • http://www.rpg-maker.org
Erreur 403 Forbidden Avec Ma Config Php Sous Linux
« Réponse #10 le: 15 avril 2003 à 11:08:09 »
&lt;_&lt; je dois vraiment m'y prendre comme un ...
J'ai fait un clic droit sur le dossier www/, je l'ai mis en appartenance a "utilisateur: apache" et "groupe: apache", je redémarre apache avec restart, et... toujours pareil... Décidément ca me prend vraiment la tête, je vais essayer ce que Achil et Yann ont dis (merci a vous), et je reposte.

@+ et merci

Hors ligne anderson2

  • Connaisseur
  • ***
  • Messages: 426
    • http://www.rpg-maker.org
Erreur 403 Forbidden Avec Ma Config Php Sous Linux
« Réponse #11 le: 15 avril 2003 à 11:10:53 »
Merci! (ben oui, 2 min. après ca marche  :o )

Merci a vous tous, me reste plus qu'a installer MySql  :rolleyes:.
 

Hors ligne achil

  • Habitué
  • **
  • Messages: 178
Erreur 403 Forbidden Avec Ma Config Php Sous Linux
« Réponse #12 le: 15 avril 2003 à 16:27:40 »
de rien.

Hors ligne anderson2

  • Connaisseur
  • ***
  • Messages: 426
    • http://www.rpg-maker.org
Erreur 403 Forbidden Avec Ma Config Php Sous Linux
« Réponse #13 le: 16 avril 2003 à 18:20:19 »
bonjour,
 :( Encore un nouveau problème: J'installe mysql, cool, mais maintenant, ben quand je veux ouvrir des pages .php, Konqueror me demande si je veux ouvrir ou enregistrer le fichier... Aparement apache ne tient plus compte du PHP...
Quelqu'un aurait il une idée d'ou ca vient? (avant que je réinstalle PHP....)

Merci encore

@+

 

Hors ligne anderson2

  • Connaisseur
  • ***
  • Messages: 426
    • http://www.rpg-maker.org
Erreur 403 Forbidden Avec Ma Config Php Sous Linux
« Réponse #14 le: 17 avril 2003 à 19:20:19 »
up  desespéré :unsure: merci