Auteur Sujet: Probleme D'upload De Fichier Avec Ipb 1.3  (Lu 2182 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne mejero

  • Débutant
  • *
  • Messages: 8
Probleme D'upload De Fichier Avec Ipb 1.3
« le: 02 Décembre 2003 à 17:59:46 »
Ca remonte surement a pas mal de temps quand les chemins physiques de nos répertoires ont été changer pour passer de : /home/users/lelogin/www/monrep  à  /home/users/lapremierelettredulogin/lelogin/www/monrep

Miraculeusement les upload marchait tjrs ... avec la vieille config. Je sais pas trop pourquoi et j'ai pas envie de le savoir.
Depuis que j'ai installé la v1.3 finale de IPB, j'ai mis les bons chemins (/home/users/lapremierelettredulogin/lelogin/www/uploads/ par exemple) et donc le forum marche bien sauf pour l'upload de fichier par les membres du forum.

En gros si j'utilise l'ancienne config (qui marchait jusqu'a la semaine derniere) ca me met que le fichier doit etre trop gros ou dans un mauvais format (en aucun cas un probleme de chemin) et si je met la nouvelle config, la c'est la catastrophe ! En gros quelqu'un qui essaye d'uploader un fichier faisait simplement planter le forum, et on ne peut plus accèder au post dans lequel il a uploadé son fichier.

Donc en gros la je me sens totalement désarmé, aucun probleme de ce genre sur les forum IPB, donc j'en conclu que c un probleme lié avec le(s) chemin(s) relatif au forum... mais lequel ?

Merci de votre aide.

PS : j'ai deja tenté de mettre le rep upload en 777 ca change rien :(

Hors ligne Risingson99

  • Connaisseur
  • ***
  • Messages: 418
    • http://www.dabox.tk
Probleme D'upload De Fichier Avec Ipb 1.3
« Réponse #1 le: 02 Décembre 2003 à 23:24:52 »
Vérifie dans la configuration global du forum et sur ton conf_global.php que les chemins sont corrects.
Sinon, demande un coup de mains de IBF  http://www.ibf-french.com/

Hors ligne bodyguard

  • Expert
  • ****
  • Messages: 576
    • http://
Probleme D'upload De Fichier Avec Ipb 1.3
« Réponse #2 le: 03 Décembre 2003 à 21:18:26 »
La reponse ICI ;)  

Hors ligne mejero

  • Débutant
  • *
  • Messages: 8
Probleme D'upload De Fichier Avec Ipb 1.3
« Réponse #3 le: 08 Décembre 2003 à 20:11:52 »
J'ai pas pu consulter depuis un moment :(

Donc deja merci de votre aide, ensuite je pense que mon message est pas clair ou alors j'ai pas bien compris le sujet sur ibf. En effet j'ai deja fait la modif du chemin et j'ai bien vérifié que le chemin est correct dans le fichier de conf. J'ai aussi vérifié les droits sur le rep d'upload. Mais rien n'y fait.

Donc je souhaite toujours avoir de l'aide :( Merci

Hors ligne Dash

  • Débutant
  • *
  • Messages: 61
    • http://www.phpnet.org/forum/index.php?showuser=454
Probleme D'upload De Fichier Avec Ipb 1.3
« Réponse #4 le: 09 Décembre 2003 à 00:29:57 »
Bonsoir,

Besoin d'un check up pour votre installation IPB ?
Invision Tools propose un script qui va vérifier et vous informer sur bon nombre de paramètres de votre installation IPB

Voir ici http://www.invisiontools.com/index.php?p=d...nloads&fileid=8

Citer
Reports:
PHP Version
Zend Version
MySQL Version
Safe Mode Status

MySQL Info Verified
Host, Username, Password
Database Name
Table Prefix

Paths Checked:
Base Path
HTML Path
Uploads Path
(Side note: Script now checks Win32 path formatting)

Directories Checked
Board Directory URL
HTML Directory URL
Uploads Directory URL

CHMOD Settings Verified:
./conf_global.php
./archive_in/
./archive_out/
./uploads/
./html/emoticons/
./lang/
./Skin/
./style_images/

Misc:
Automatically applies common Lycos fixes if needed
Calculates and reports total number of errors
Checks if the ini_get() function is available
Displays the board
Restore Admin Account (only in the event the Admin demoted themselves for security purposes)

Je pense que vous devriez essayer cet outil de diagnostic.
 :P
« Modifié: 09 Décembre 2003 à 00:56:39 par Dash »

Hors ligne Risingson99

  • Connaisseur
  • ***
  • Messages: 418
    • http://www.dabox.tk
Probleme D'upload De Fichier Avec Ipb 1.3
« Réponse #5 le: 09 Décembre 2003 à 14:39:23 »
hum... intéressant ce piti script  :)  

Hors ligne mejero

  • Débutant
  • *
  • Messages: 8
Probleme D'upload De Fichier Avec Ipb 1.3
« Réponse #6 le: 10 Décembre 2003 à 11:39:13 »
Super ce petit script, je connaissais pas :)

Citer
The Debug script found the following:
Server Environment
 PHP Version 4.3.4
 Zend Version 1.3.0
 MySQL Version 3.23.49-log
 Safe mode is Off

SQL Details
 SQL Host, Username and password is Correct
 SQL Database Name is Correct
 SQL Table Prefix is Correct


Directory Naming
 The Directory archive_in is named correctly.
 The Directory archive_out is named correctly.
 The Directory cache is named correctly.
 The Directory html is named correctly.
 The Directory lang is named correctly.
 The Directory modules is named correctly.
 The Directory Skin is named correctly.
 The Directory sources is named correctly.
 The Directory ssi_templates is named correctly.
 The Directory style_images is named correctly.
 The Directory uploads is named correctly.

Paths
 Your HTML Path is correct
 Your Base Path is correct
 Your Upload Path is correct

URLs
 Your Board Directory URL is correct
 Your HTML Directory URL is correct
 Your Uploads Directory URL is correct

File Permissions(CHMOD)
 /home/users/i/irbesancon/www/forum/conf_global.php is set to the correct permissions
 /home/users/i/irbesancon/www/forum/archive_in/ is set to the correct permissions
 /home/users/i/irbesancon/www/forum/archive_out/ is set to the correct permissions
 /home/users/i/irbesancon/www/forum/cache/ is set to the correct permissions
 /home/users/i/irbesancon/www/forum/uploads/ is set to the correct permissions
 /home/users/i/irbesancon/www/forum/html/emoticons/ is set to the correct permissions for uploading emoticons from the AdminCP
 /home/users/i/irbesancon/www/forum/lang/ is set to the correct permissions for importing language packs.
 /home/users/i/irbesancon/www/forum/Skin/ is set to the correct permissions for importing skins
 /home/users/i/irbesancon/www/forum/sources/ is set to the correct permissions.
 /home/users/i/irbesancon/www/forum/sources/Admin/ is set to the correct permissions.
 /home/users/i/irbesancon/www/forum/sources/Drivers/ is set to the correct permissions.
 /home/users/i/irbesancon/www/forum/sources/lib/ is set to the correct permissions.
 /home/users/i/irbesancon/www/forum/sources/misc/ is set to the correct permissions.
 /home/users/i/irbesancon/www/forum/style_images/ is set to the correct permissions for importing skins


Evaluation
The Debug Script calculated 0 errors

If you are experiencing a MySQL Error Number of 145 or 1016 then you will have to REPAIR the table either via the MySQL Toolbox in the Admin CP or in PHPMyAdmin.


Donc en gros tout va bien, mais l'upload marche pas :(

vetofish

  • Invité
Probleme D'upload De Fichier Avec Ipb 1.3
« Réponse #7 le: 10 Décembre 2003 à 22:08:16 »
Je n'utilise pas IPB, mais depuis le une semaine environ, alors que je n'ai rien touché sur les script, impossible d'uploader des photos sur mon sute, ni même d'envoyer des pièces jointes par mon formulaire de contact (encodage base64).

Il doit y avoir une fonction qui a n'a pas été activée par rapport à l'ancienne configuration ... je cherche encore ...

Hors ligne mejero

  • Débutant
  • *
  • Messages: 8
Probleme D'upload De Fichier Avec Ipb 1.3
« Réponse #8 le: 14 Décembre 2003 à 19:02:19 »
Vas encore falloir attendre 15 jours la reponse du "service technique" quoi ... :(