PHPNET Assistance

Informations PHPNET => Forum Technique et Commercial => Discussion démarrée par: jeanmi67 le 31 décembre 2013 à 13:53:46

Titre: Problème en cours (31/12/2013) ?
Posté par: jeanmi67 le 31 décembre 2013 à 13:53:46
Bonjour,

Il est actuellement impossible d'accéder à un de mes sites :

Database Connection Failed
Error: Can't connect to MySQL server on 'cl1-sql7' (111) (2003)
Function Performed: CONNECT
Host/DB: cl1-sql7/xxxxxxxx
Database Type: mysqli

Je ne vois rien sur la page "Etat du réseau".

Cordialement.
Jeanmi67
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: phil54 le 31 décembre 2013 à 14:51:36
Même problème avec message : "Warning: mysql_connect() [function.mysql-connect]: Lost connection to MySQL server at 'reading initial communication packet'

Espérons que cela soit rapidement réparé
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: thibaud le 31 décembre 2013 à 15:08:56
Nous avons un gros incident sur ce serveur.
Nous travaillons activement sur le sujet.
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: jeanmi67 le 31 décembre 2013 à 15:11:54
Merci pour ce retour.
Bon courage à l'équipe à quelques heures du réveillon...
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: jeanmi67 le 31 décembre 2013 à 15:45:39
Site revenu depuis quelques minutes.
Merci aux intervenants.
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: kriekbellevue le 01 janvier 2014 à 09:26:02
Moi j'ai toujours des restes ...
Ne fonctionne pas à encore 100%.
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: phil54 le 01 janvier 2014 à 11:07:00
Toujours des problèmes de connexion (cl1-sql7) avec l'erreur : "Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock'"
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: oimou le 01 janvier 2014 à 11:10:59
impossible d'enregistrer quoi que ce soit dans la base depuis hier après midi!!! erreur storage engine...
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: jeanmi67 le 01 janvier 2014 à 11:15:02
Et pour moi, les images captcha ne sont plus générées (ou plus accessibles).
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: thibaud le 01 janvier 2014 à 13:29:18
il y a un gros souci d'innodb.
On fait une extraction de toutes les bases en ce moment et nous allons les reimporter sur un autre serveur.
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: Tomeko le 01 janvier 2014 à 14:16:08
Bon courage à vous !
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: phil54 le 01 janvier 2014 à 15:40:06
Plus aucun script ne fonctionne pour les accès à la base sql cl1-sql7

Exemple d'erreur : "Warning: mysql_fetch_row() expects parameter 1 to be resource, boolean given in"

Je suppose que la réinstallation des bases n'est pas terminée, mais dans le doute, je poste...
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: VeuillezPLP le 01 janvier 2014 à 18:07:42
Bonjour,

Y a t-il moyen de savoir sur quel serveur SQLnos bases ont été installées?

Cordialement
Titre: Re : Re : Problème en cours (31/12/2013) ?
Posté par: jeanmi67 le 01 janvier 2014 à 18:30:17
Y a t-il moyen de savoir sur quel serveur SQLnos bases ont été installées?
Pour un hébergement mutualisé : dans le panel de gestion de celui-ci, dans la partie "Vos bases de données"
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: marckisscool le 01 janvier 2014 à 18:45:00
Toutes les bases sur les mutualisés sont hs depuis 17h!
cl1-sql7
cl1-sql6
cl1-sql3
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: Chimere le 01 janvier 2014 à 18:57:13
Bonjour,
Je suis novice mon site également ne fonctionne plus...(Link to database cannot be established: SQLSTATE[HY000] [2013] Lost connection to MySQL server at 'reading initial communication packet', system error: 111) est-ce que je dois faire quelque chose à mon niveau ou attendre simplement un retour à la normal ???

Merci
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: VeuillezPLP le 01 janvier 2014 à 19:00:16
Le mieux est d'attendre car les bases ne sont plus là où elles sont censés être.
Titre: Re : Re : Problème en cours (31/12/2013) ?
Posté par: Chimere le 01 janvier 2014 à 19:05:50
Le mieux est d'attendre car les bases ne sont plus là où elles sont censés être.

Merci, Ok je vais attendre que mon site réapparaisse !!
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: thibaud le 01 janvier 2014 à 19:59:30
Il n'y a que les bases de cl1-sql7 qui sont impactés, pas les autres serveurs...

Le bug dans le moteur innoDB nous oblige a réimporter toutes les bases a partir de leur source au format SQL.
Ceci prend du temps malheureusement.
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: VeuillezPLP le 01 janvier 2014 à 20:52:00
Les bases SQL sont celles d'avant le bug au niveau ou d'un backup de chez vous qui ne date pas d'aujourd'hui?

Merci en tout cas de nous tenir au courant.
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: phil54 le 01 janvier 2014 à 22:19:12
Toujours HS pour moi depuis ce matin !!

Super pour le référencement des sites...
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: rahan le 02 janvier 2014 à 06:52:45
Encore HS ce matin
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: marckisscool le 02 janvier 2014 à 07:42:25
HS et zero information, a t'on espoir qu'un jour ça remarche?
Y'avait une equipe avant, c'est fini on a plus le droit d'etre informé?
Les equipements ne sont pas doublés?
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: thibaud le 02 janvier 2014 à 08:23:02
Bonjour
Il ne s'agit pas d'un probleme d'équipement mais un d'un problème de corruption des données par le moteur InnoDB en lui même.
Nous avons été obligé de réimporter toutes les bases sur un serveur vierge a partir des exports que nous avons préalablement fait sur le serveur de prod qui fonctionnait pas en mode forcé et donc avec les données en lecture seule.

La réimportation sur Mysql prend du temps malheureusement mais elle est presque terminée ce matin.
Je pense qu'avant 12h, tout devrait etre réimporté.
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: marckisscool le 02 janvier 2014 à 08:40:47
Bonjour Thibaud

Hmmm le moteur InnoDB n'est pas le même sur tous les serveurs sql, parce que là je comprend pas bien pourquoi du jour au lendemain le moteur InnoDB pourri les fichiers??? Et je croyais que les serveurs sql etait doublé, les 2 moteurs sont defaillants ou c'est juste une image du disque et donc des fichiers physiques?

Effectivement si c'est export puis import (bien que si le moteur InnoDB a pourri les données on risque d'en hériter), le temps de remise en service s'explique.


Merci pour ces infos thibaud (au passage bonne année et meilleurs voeux, même si on a connu mieux ;) )
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: thibaud le 02 janvier 2014 à 08:50:35
Nous n'avons pas d'explication sur l'origine du problème... Visiblement ceci serait lié a un bug dans le moteur innoDB.
En gros, mysql a Crashé sans raison le 31 vers 13h.
Nous avons simplement relancé mysql sauf qu'il n'a jamais voulu réparer le journal innoDB, Mysql crashait juste après la fin de l'analyse du journal.
Nous avons donc activé le force-recovery et là Mysql tournait mais avec les données en read Only.
Nous avons du coup été obligés d'exporter les données en SQL puis de les réimporter sur un serveur "vierge".

Entre temps, nous avons évidemment fait un certain nombre d'essais (changement de versions, mariaDB => Mysql, etc etc).

En bref, une mauvaise fin d'année...
Meilleurs voeux tout de même également a vous tous,
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: VeuillezPLP le 02 janvier 2014 à 09:04:24
Merci en tout cas des informations et bon courage!

Y a plus qu'à attendre.
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: marckisscool le 02 janvier 2014 à 09:13:30
Thibaud,
j'ai pas percuté en te lisant mais pourquoi de l'InnoDB pour des bases destinées à du web? Le MYIsam est beaucoup plus approprié mais cela implique de modifier la gestion faite par le produit phpmyadmin, sorti de ça, le InnoDB est plus approprié pour du dédié à mon sens, et je parle meme pas de la facilité de backup sur du MyIsam.
Le seul avantage du InnoDB est c'est là ou le bas blesse un peu c'est la securisation des données pour eviter d'avoir des données corrompues, visiblement ça marche pas bien chez oracle :)
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: Hobbes82 le 02 janvier 2014 à 09:21:30
Bonjour,
Après votre transfert, il n' y aura rien de particulier à faire ?
La base sera toujours sur serveur cl1-Sql7 ou il faut changer qque chose dans le fichier settings.inc.php ?
Je stresse un peu de perdre mes dernières commandes du 31/12 non encore traitées.

Titre: Re : Problème en cours (31/12/2013) ?
Posté par: thibaud le 02 janvier 2014 à 09:36:55
La réimportation est terminée.
Il reste un petit pourcentage de bases pour lesquelles cela n'a pas fonctionné.
Nous traitons ces cas en ce moment.

Tout devrait être terminé rapidement.
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: kriekbellevue le 02 janvier 2014 à 09:45:15
Chez moi, tout à l'air bon.
Merci.
Titre: Re : Re : Problème en cours (31/12/2013) ?
Posté par: Dimitri01 le 02 janvier 2014 à 09:46:01
pourquoi de l'InnoDB pour des bases destinées à du web? Le MYIsam est beaucoup plus approprié

Je me la mets de côté celle-là, elle est bien bonne !  :huh:
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: Hobbes82 le 02 janvier 2014 à 10:05:49
La taille de ma base est passée à 0Mo dans le panel et impossible d'y accéder elle semble vide.
J'ai une 2eme base qui me sert pour des tests sur ce même serveur qui pour sa part est pourtant accessible.

Un petit message pour me rassurer serait le bienvenu.
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: thibaud le 02 janvier 2014 à 10:09:40
http://status.phpnet.org/index.php?do=details&task_id=8&project=0
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: marckisscool le 02 janvier 2014 à 10:19:00
Citation de: Dimitri01
pourquoi de l'InnoDB pour des bases destinées à du web? Le MYIsam est beaucoup plus approprié

Je me la mets de côté celle-là, elle est bien bonne !  :huh:
Jusqu'à 40 fois plus rapide et beaucoup moins gourmand en espace disque.
Là on parle de mutualisés qui en général servent à héberger des scripts courants type forum blog etc..... Aucun intérêt d'avoir du InnoDB, bientôt on va monter de l'oracle 11G pour de l'hebergement de forum.....  :huh:
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: jeanmi67 le 02 janvier 2014 à 10:21:04
Bonjour,

Et pour les site "revenus" mais cassés, il faut ouvrir un ticket ?
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: thibaud le 02 janvier 2014 à 10:33:34
oui
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: marckisscool le 02 janvier 2014 à 10:33:59
Thibaud l'import n'aurait pas fait l'impasse sur certaines tables? il me manque des tables dans les bases de données.
Titre: Re : Re : Problème en cours (31/12/2013) ?
Posté par: jeanmi67 le 02 janvier 2014 à 10:40:57
oui
C'est fait !
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: thibaud le 02 janvier 2014 à 10:42:05
Il semble que ca soit les tables marquées crashé qui n'ont pas été dumpées.
On fait une reparation de ces tables puis on va les importer dans la journée.
Si vous les avez en backup, remettez les en attendant pour vous faire gagner du temps.
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: Dimitri01 le 02 janvier 2014 à 11:00:18
@marckisscool

Il est stupide d'affirmer, comme tu le fais, que le moteur MyIsam et ses énormes lacunes est le plus approprié pour internet, alors même que les "vrais" serveurs de bases de données ne proposent pas ce type de moteur ! Il peut être utile de regarder ce qui se fait ailleurs avant d'affirmer des généralités.

MyIsam est très rapide car ce n'est finalement qu'un simple fichier plat ! Alors oui, parfois, utiliser un fichier plat peut être suffisant. Mais même là, il ne faut pas généraliser. Dans certains cas (nombreuses éditions), MyIsam devient plus lent que innodb !

Mais même pour un simple forum, comme tu le dis (et pour en avoir développé from scratch, je pense savoir de quoi je parle) tu dois utiliser des transactions pour sécuriser les opérations effectuées sur les tables. Or le moteur MyISAM ne le permet pas.

Je t'invite à lire ceci, par exemple : MySQL poudre aux yeux (http://blog.developpez.com/sqlpro/p9136/langage-sql-norme/mysql_un_sgbdr_poudre_aux_yeux) ;-)

Bon, évitons peut-être de troller ici  -_-
Titre: Re : Re : Problème en cours (31/12/2013) ?
Posté par: jeanmi67 le 02 janvier 2014 à 11:04:40
Si vous les avez en backup, remettez les en attendant pour vous faire gagner du temps.
Le restore du dump du 30 décembre termine en erreur :angry:
Je préfère attendre votre intervention...
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: Frederic_vav le 02 janvier 2014 à 11:21:19
J'ai ouvert un ticket pour mon site www.volavoile.net toujours HS

Bon courage,

Titre: Re : Problème en cours (31/12/2013) ?
Posté par: thibaud le 02 janvier 2014 à 11:37:30
Nous travaillons actuellement sur :
- les bases manquantes totalement - retour a la normale d'ici peu
- les tables manquantes sur certaines bases - retour maxi en fin d'apres midi
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: casa le 02 janvier 2014 à 11:49:50
Bonjour,
Sur cl1-sql7 tout semble remarcher.

bonne année.
casa
Titre: Re : Re : Problème en cours (31/12/2013) ?
Posté par: marckisscool le 02 janvier 2014 à 12:00:09
Nous travaillons actuellement sur :
- les bases manquantes totalement - retour a la normale d'ici peu
- les tables manquantes sur certaines bases - retour maxi en fin d'apres midi
Tu peux les reimporter totalement, y'a pas une base de données qui est remontée correctement pour ma part sur le cl1-sql7, un petit coup d'optimisation des tables avant l'export et encore y'a des tables sans activité qui devrait etre là et qui ne le sont pas.
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: VeuillezPLP le 02 janvier 2014 à 12:55:19
L'administration Wp de mon site refonctionne mais est excessivement lent, y a d'autres soucis de performances en cours?
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: Frederic_vav le 02 janvier 2014 à 13:02:02
OK pour www.volavoile.net

(merci)
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: spi-dclic le 02 janvier 2014 à 13:18:32
Chez nous le site est de nouveau en ligne mais il est impossible d'ajouter au panier et de passer commande.

Nous sommes sur prestashop 1.4.9

Quelqu'un à t'il le même problème?
Titre: Re : Re : Problème en cours (31/12/2013) ?
Posté par: marckisscool le 02 janvier 2014 à 13:35:23
Chez nous le site est de nouveau en ligne mais il est impossible d'ajouter au panier et de passer commande.

Nous sommes sur prestashop 1.4.9

Quelqu'un à t'il le même problème?
Verifiez que vous ayez la totalité de vos tables, c'est pas parce que c'est en ligne que l'import a bien marché, sur chaque base il me manque 10 à 15 tables, sur presque 12 bases, thibaud conseille d'ouvir un ticket pour signaler un soucis de table ou de base.
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: spi-dclic le 02 janvier 2014 à 13:36:22
Merci du renseignement j'ouvre un ticket de suite !
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: rahan le 02 janvier 2014 à 15:46:41
Pas encore opérationnel pour http://david-photographie.fr/  sur cl1-sql7
J'attend jusqu'à ce soir avant d'ouvrir un ticket
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: phil54 le 02 janvier 2014 à 15:48:04
Ticket ouvert également de mon coté (manque 3 tables sur 13)

En espèrant que toutes les données déjà importées soit correctes ; les quelques tests pour l'instant semblent bons...
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: jeanmi67 le 02 janvier 2014 à 17:52:42
Site de nouveau complètement opérationnel depuis une trentaine de minutes.
Merci aux intervenants.
Titre: Re : Re : Problème en cours (31/12/2013) ?
Posté par: rahan le 02 janvier 2014 à 17:56:11
Pas encore opérationnel pour http://david-photographie.fr/  sur cl1-sql7
J'attend jusqu'à ce soir avant d'ouvrir un ticket


Ok pour moi
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: thibaud le 02 janvier 2014 à 17:56:35
Toutes les tables manquantes ou bases non dumpées doivent de nouveau etre disponibles.
Est-ce ok pour tout le monde ?
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: marckisscool le 02 janvier 2014 à 18:17:11
C'est ok thibaud tout est là, merci
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: Hobbes82 le 02 janvier 2014 à 18:27:16
Le site rame ! 15 à 30 secondes pour ouvrir une page...
(http://img842.imageshack.us/img842/2977/vrij.jpg)
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: VeuillezPLP le 02 janvier 2014 à 19:15:01
(http://veuillezparlapresente.com/img/Capture-vitesse.JPG)

Rien à reprocher de mon côté.
L'admin remarche parfaitement et le site est rapide.
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: phil54 le 02 janvier 2014 à 19:29:52
A priori, c'est bon pour moi aussi
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: Hobbes82 le 02 janvier 2014 à 19:44:44
Ça ne s'arrange pas ! Quelle calamité !!
Dois-je effectuer la migration vers un autre serveur ?
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: phr le 02 janvier 2014 à 19:57:18
Piwik ne fonctionne plus et je ne parviens pas à faire une réinstall, normal ou pas ?
Des choses ont-elles été désactivées ?
J'ai le message suivant quand je me logg sur le dossier
Parse error: syntax error, unexpected T_STRING, expecting T_CONSTANT_ENCAPSED_STRING or '(' in /home/users4/e/eole/www/piwik/index.php on line 11
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: aggelos le 02 janvier 2014 à 23:06:13
Bonsoir,

Notre base n'est pas du tout rétablie. Il n'y a plus qu'un compte utilisateur sur la centaine qui avait été créé sur notre Wordpress (même le compte admin a disparu). Tous les articles ont disparus (les articles exemples de Wordpress lors d'une installe nouvelle sont là par contre...).

Je soumet de nouveau un ticket. Merci de faire tout ce que vous pouvez rapidement, c'est une base extrêmement utilisée.
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: thibaud le 03 janvier 2014 à 00:56:30
aggelos, j'ai fait le necessaire pour vous base.
Il reste quelques bases "exceptionnelles" sur lesquelles cela a pu faire cela...
nous allons corriger cela rapidement pour les autres qui seraient dans ce cas.

phr, l'erreur ne semble pas lié a la base mais il faut vérifier avant de votre coté.
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: Hobbes82 le 03 janvier 2014 à 11:11:58
Problèmes de performance réglés dans la nuit.

Merci à toute l'équipe et meilleurs vœux.

Une question : Est-il possible d'avoir une base donnée répliquée en temps réel sur un autre serveur (comme une image disque) afin de pouvoir basculer instantanément d'un serveur à l'autre en cas d'indisponibilité du serveur actif ?
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: marckisscool le 03 janvier 2014 à 16:55:14
Bonjour,

Que va t'on mettre en oeuvre chez phpnet pour ne plus avoir ce genre de soucis?
Un outil permettant d'importer les saves phpnet autrement que par phpmyadmin serait pertinent dans un pareil cas, non?
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: Holo le 04 janvier 2014 à 12:37:59
Bonjour à vous, le problème est toujours présent sur mon site : http://www.alexdor.info/index2.php.

J'avais ouvert un ticket il y a 2 jours à ce sujet. Je ne peux même pas accéder à la base de données pour pouvoir transvaser les données sur un autre serveur.

Pouvez-vous m'aider sur ce point svp ? De nombreux utilisateurs du site ont besoin d'y accéder rapidement.

Merci !

EDIT : Ok, j'ai eu la réponse à mon ticket.
Titre: Re : Re : Problème en cours (31/12/2013) ?
Posté par: phr le 04 janvier 2014 à 13:17:55
phr, l'erreur ne semble pas lié a la base mais il faut vérifier avant de votre coté.

Bonjour Thibaud, tous mes voeux pour cette nouvelle année.
Concernant piwik, je fais un retour, la mise à jour nécessitait une version plus récente de php.
@+
Phil
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: phil54 le 22 janvier 2014 à 12:09:37
Depuis hier, nouveaux ralentissements SQL sur le cl1-sql7 et ce matin, quelques erreurs "MySQL server has gone away"

Comme ça avait déjà commencé de cette façon les jours précédents le dernier gros problème sur ce serveur, je m'inquiète un peu...
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: thibaud le 22 janvier 2014 à 15:51:51
Bonjour,

Vérification faite, il n'y a pas eu d'incident sur ce serveur ce matin et le derniere reboot de mysql date de l'incident.

Il n'y a donc rien de spécial de notre coté.
Si vous avez un premium, nous avons eu un souci de charge sur l'un de nos hotes premium ce matin, ceci explique peut etre les erreurs que vous avez rencontré.
Titre: Re : Problème en cours (31/12/2013) ?
Posté par: phil54 le 22 janvier 2014 à 16:43:22
J'ai effectivement un Premium, et les erreurs ont eu lieu ce matin entre 10 h 43 et 10 h 46, depuis ça fonctionne mais je préférais le signaler, on ne sait jamais...