PHPNET Assistance

Support et Entraide PHPNET => Serveur dédié et virtuel => Discussion démarrée par: Bobdu35 le 17 octobre 2014 à 22:54:51

Titre: Fonction mail() ne fonctionne plus
Posté par: Bobdu35 le 17 octobre 2014 à 22:54:51
Bonjour,

Sans raison apparente, la fonction mail() ne fonctionne plus depuis aujourd'hui vers 16H00 environ, suite à un reboot du serveur qui n'était pas de mon fait. Ci-joint une des erreurs apparaissant dans /var/log/mail.err :

Oct 17 15:57:37 v1769 postfix/sendmail[1807]: fatal: could not find any active network interfaces

Est-ce lié à l'interface réseau ?

Merci de votre aide, sachant que les inscriptions et notifications de mon site ne sont donc plus fonctionnelles.
Titre: Re : Fonction mail() ne fonctionne plus
Posté par: Sellig33 le 18 octobre 2014 à 08:19:34
Bonjour,

regarde aussi la configuration réseau

gilles
Titre: Re : Fonction mail() ne fonctionne plus
Posté par: Bobdu35 le 18 octobre 2014 à 10:53:22
Bonjour,

Ci-joint ma config réseau, telle que définie par défaut, ce qui m'étonne c'est le 127.0.0.2 ?!
Par contre très risqué d'y toucher, c'est scier la branche sur laquelle on est assis ;-)

auto lo
iface lo inet loopback
# Auto generated venet0 interface
auto venet0
iface venet0 inet manual
up ifconfig venet0 up
up ifconfig venet0 127.0.0.2
up route add default dev venet0
down route del default dev venet0
down ifconfig venet0 down
auto venet0:0
iface venet0:0 inet static
address 194.110.192.213
netmask 255.255.255.255
Titre: Re : Fonction mail() ne fonctionne plus
Posté par: Bobdu35 le 18 octobre 2014 à 13:49:05
Bonjour,

Problème résolu  ^_^

J'ai fouillé les logs sans même regarder le status de Postfix qui était tombé  :rolleyes: