PHPNET Assistance

Informations PHPNET => Forum Technique et Commercial => Discussion démarrée par: maxiclene le 04 décembre 2004 à 14:52:26

Titre: Base Sql
Posté par: maxiclene le 04 décembre 2004 à 14:52:26
Bonjour,

je souhaitez savoir si il etait prévus de mettre a jour notre version de MySQL qui est la 3.23.49 sur le Cluster 1, car celle ci commence a daté et des scripts php ne sont pas pris en charge par cette version a cause de l'encienneté. :unsure:

Merci de votre réponce.

Max

 
Titre: Base Sql
Posté par: Ice le 04 décembre 2004 à 15:27:47
vi , MySQL 3.23.49 sur le serveur 1
et MySQL 4.0.17 sur le serveur 2 :)
Titre: Base Sql
Posté par: maxiclene le 07 décembre 2004 à 14:56:53
Alors pas de réponse officiel ?

Max
Titre: Base Sql
Posté par: HoPHP le 08 décembre 2004 à 12:43:27
Je crois qu'une mise à jour de MySQL à la dernière version stable et de PHP à la dernière version stable seraient très très appréciées. Ceux qui auront des scripts qui pêcheront, je dirais presque "tant pis pour eux"...

Je croyais que
Citer
Faire confiance à PHPNET c'est l'assurance... (...) ...d'être toujours à la pointe de la technologie du Web dynamique
(http://www.phpnet.org/ ) ( !!!!!!!!! ) .

Pour moi, être à la pointe, actuellement, depuis bientôt 3 mois, c'est le PHP5 et les dernières version de MySQL. Ne stoppont pas la marche vers l'avenir du web dynamique.

Ceux qui ont des scripts mal écrits (= non compatibles PHP5), ils ont qu'à s'y mettre, la liste des incompatibilités n'est pas si longue. On les aidera ici, sur ce forum (s'il fonctionne encore (sic) ) si nécessaire, mais je crois qu'on paye nos hébergements (mutualisés aussi !) chez PHPNet pour être "à la pointe de la technologie du Web dynamique" !!!

Personellement, je compte pas mal là-dessus. J'attends la mise à jour de PHPNet vers le PHP5 pour pouvoir ENFIN utiliser toutes les possibilités supplémentaires offertes par ce langage !

Voilà, j'ai poussé mon coup de gueule, mais ça fait un moment qu'on attend !!! ça devient urgent !

Soit on dit qu'on est à la pointe et on s'y tient, soit on ne le dit pas !!!  :ph34r:

:angry: GRRRR :angry:  GRRRRR :angry:

Vivement le PHP5, je crois que ça devient définitivement URGENT !!!!!!!   :ph34r:

@+, pas si faché que ça quand même,

HoPHP
Titre: Base Sql
Posté par: Fozzy le 08 décembre 2004 à 12:49:52
tout dépend ce qu'on appelle être à la pointe.
Si c'est bénéficier des tout derniers bugs alors effectivement il faut toujours installer la dernière version sortie de chaque produit en demandant aux 3000 clients et plus de recoder leurs 20 000 sites pour satisfaire une petite dizaine de clients.
Si c'est bénéficier d'une solution stable et performante permettant à tous les internautes y compris ceux qui ne sont pas informaticiens d'avoir un site fonctionnel alors autant attendre qu'une nouvelle version soit parfaitement stable
Titre: Base Sql
Posté par: maxiclene le 09 décembre 2004 à 16:57:37
Toujour pas de réponse officiel ?   :unsure:

il n'y a pas d'administrateur ?  :blink:


 
Titre: Base Sql
Posté par: Freelance le 09 décembre 2004 à 17:29:05
Le réponse est sur le site à cette adresse :
http://www.phpnet.org/?PHPSESSID=2addcd0b9...abed&p=serveurs (http://www.phpnet.org/?PHPSESSID=2addcd0b9a81d0268eb308a3359cabed&p=serveurs)
Titre: Base Sql
Posté par: HoPHP le 09 décembre 2004 à 20:15:06
Citer
tout dépend ce qu'on appelle être à la pointe.
Si c'est bénéficier des tout derniers bugs alors effectivement il faut toujours installer la dernière version sortie de chaque produit en demandant aux 3000 clients et plus de recoder leurs 20 000 sites pour satisfaire une petite dizaine de clients.
Si c'est bénéficier d'une solution stable et performante permettant à tous les internautes y compris ceux qui ne sont pas informaticiens d'avoir un site fonctionnel alors autant attendre qu'une nouvelle version soit parfaitement stable
Oui, si on veut. Je suis d'accord.

Pourquoi dans ce cas, on n'aurait pas droit à l'extension *.php5 ? Si ça se fait autre part, pourquoi pas chez PHPNet ? Je me tiens tout de même au "pointe de la technologie du Web dynamique" ! On paye pour ça, non ? "On paye" = "contrat" = "respect des clauses", non ?

Bon, je vais pas troller, je suis tout de même satisfait de PHPNet, mais le PHP5 me manque :'( :-D

@+, HoPHP
Titre: Base Sql
Posté par: maverick78 le 09 décembre 2004 à 20:40:46
si phpnet juge plus stable php4 il est en devoir de le laisser...
rien n'indique contractuellement qu'il doit passer a php5!
c'est pas parceque c'est nouveau que c'est forcement mieux...
Titre: Base Sql
Posté par: HoPHP le 09 décembre 2004 à 22:05:20
Citer
c'est pas parceque c'est nouveau que c'est forcement mieux...
Pas forcément, d'accord. Mais c'est pas pour rien qu'une nouvelle version est faite, non ? Je ne me fais pas trop d'illusions, il y a deux solutions:
. soit PHPNet s'obstine à ne pas mettre à jour sa version de PHPNet (pourquoi pas ?) et lorsque le monde du web considérera que le PHP5 (et suivantes) est LA technologie incontournalbe. Dans ce cas, PHPNet fera de moins en moins de clients (je ne le souhaite pas, loin de là).
. soit PHPNet offre (temporairement) cette technologie du futur (par le biais d'une extension .php5, par exemple) et prévoit de rester à jour, dans le courant de l'avancée des technologies, car il ne faut pas rêver, le PHP va continuer à se faire développer, quoi qu'on fasse...

J'ai dit.
Titre: Base Sql
Posté par: maxiclene le 10 décembre 2004 à 01:41:54
Je comprend pas Freelance ! je suis aller à ton adresse

http://www.phpnet.org/?PHPSESSID=2addcd0b9...abed&p=serveurs (http://www.phpnet.org/?PHPSESSID=2addcd0b9...abed&p=serveurs)

mais a part les chemas et les descriptions des serveurs je vois rien d'autre.

Je souhaite savoir si il est prévus que phpnet upgrade sa version de SQL sur le cluster 1. :huh:

Max
Titre: Base Sql
Posté par: Carssou le 10 décembre 2004 à 09:58:16
Citer
si phpnet juge plus stable php4 il est en devoir de le laisser...
Est-on à jour niveau PHP4 ?
Titre: Base Sql
Posté par: Sasayaki no karasu le 10 décembre 2004 à 10:05:43
sur le #1 : php 4.3.9
sur le #2 j'ai pas trouvé de phpinfo dispo, mais je pense que c'est la meme config.
Titre: Base Sql
Posté par: Carssou le 10 décembre 2004 à 14:51:09
Merci, je viens de vérifier pour le 2 c'est bien 4.3.9

Bon ben on est à jour au niveau php4 :)
Titre: Base Sql
Posté par: maxiclene le 13 décembre 2004 à 23:19:45
Moi j'ai rien demander sur la version de php! mais sur la version de MySql  :blink:

alors y 'a t'il une réponse ou pas ?

Max
Titre: Base Sql
Posté par: Carssou le 14 décembre 2004 à 11:40:42
Phpmyadmin te donne la version utilisée:

Cluster2: MySQL 4.0.17
Cluster1: MySQL 3.23.49 :s
Titre: Base Sql
Posté par: maxiclene le 14 décembre 2004 à 19:24:27
Merci Carssou mais c'est pas la réponse que j'attend, je la reformule...

je souhaitez savoir si il etait prévus de mettre a jour notre version de MySQL qui est la 3.23.49 sur le Cluster 1, car celle ci commence a daté et des scripts php ne sont pas pris en charge par cette version a cause de l'encienneté.  

Merci de votre réponce.

Max
 
Titre: Base Sql
Posté par: thibaud le 14 décembre 2004 à 19:42:26
la mise a jour va etre faite prochainement.
Titre: Base Sql
Posté par: HoPHP le 14 décembre 2004 à 21:42:14
Génial !

PHP ? MySQL ?

Bon, ceci dit, avec un peu de recul, je tiens à modérer mes propos "acides" sur les mises à jour software. La mise à jour PHP5 demande sans doute un boulot fou (rien que coté admin, entre autre pour que ce présent forum fonctionne (sic) ) et je suis le premier à me plaindre de mon manque de temps. Je suis impatient, mais j'ai finalement le temps.

Merci Thibaud, pour le boulot FOU que tu fais (même si je ne sais pas si je m'en rends exactement compte).

@+, HoPHP
Titre: Base Sql
Posté par: juju2000 le 16 décembre 2004 à 00:25:33
D'ailleur MySQL 5 est sorti réceament  :D

Niveau php hier on a le droit à la PHP 4.3.10 et la 5.0.03

Edit: Sauf erreur je me suis trompé elle est en alpha. Par contre la 4.0.22 est bien sorti.
Titre: Base Sql
Posté par: Carssou le 16 décembre 2004 à 11:26:06
pour MySQL 5  il me semble qu'il faut recoder tous nos scripts... genre remplacer mysql_connect() par mysqli_connect() etc...
Titre: Base Sql
Posté par: juju2000 le 18 décembre 2004 à 00:41:35
Citer
pour MySQL 5  il me semble qu'il faut recoder tous nos scripts... genre remplacer mysql_connect() par mysqli_connect() etc...
Ce désagrément vient de php ou d'une spécificité de Mysql?

Aussi question de néophyte, un php 4 par exemple peut-t-il communiquer avec Mysql 5?
 
Titre: Base Sql
Posté par: Carssou le 20 décembre 2004 à 11:55:06
C'est une spécificité de MySQL 4.1.7 et pas 5 comme je l'avais dis mais ça peut être changé dans les options.

php4 peut communiquer avec MySQL 5 oui.