PHPNET Assistance

Informations PHPNET => Forum Technique et Commercial => Discussion démarrée par: StudioTchio le 16 février 2005 à 13:28:30

Titre: Mail()
Posté par: StudioTchio le 16 février 2005 à 13:28:30
Slt à tous,

J'ai un petit problème avec la fonction mail() quand j'essaye d'envoyer de mon adresse e-mail PHPNet vers un autre compte PHPNet : le mail n'arrive pas.

Le même mail envoyé vers un compte autre que PHPNet, pas de problème.

Y'en a t-il d'autre dans le même cas ?

Ps : Je suis sur le cluster 2
Titre: Mail()
Posté par: Ice le 16 février 2005 à 13:41:05
Oui, encore 1 mail que je n'ai pas recu cette nuit.
Titre: Mail()
Posté par: philipppe le 16 février 2005 à 14:57:56
[HS]
As-tu déjà visité ton site avec firefox.... Pour un site "pro" ca fait tâche  :rolleyes:
Titre: Mail()
Posté par: StudioTchio le 16 février 2005 à 15:25:57
Merci pour cette remarque pertinente Philippe, on me l'avait déjà signalé.

Je vais essayer de remedier à l'histoire (le site est lancé depuis 15 jours seulement).  On dira pour l'instant qu'il est "optimisé pour Internet Explorer"  :P

PS : J'en reste quand même à me demander pourquoi il semble si bizarre car il me semble utiliser du HTML standard.  D'ailleurs en lançant le W3C check, ça semble à quelques petites erreurs près, correct.  Mais je vous assure que je vais y jeter un oeil  ;)  
Titre: Mail()
Posté par: Ice le 16 février 2005 à 22:42:45
Encore 1 mail qui n'est pas arrivé  :angry:  
Titre: Mail()
Posté par: philipppe le 16 février 2005 à 23:33:41
ceci dit, dans la serie "tâche"... le "Hébergement de votre site chez notre provider phpnet.fr"... c'est tout sauf pro...  :rolleyes:  
Titre: Mail()
Posté par: Portekoi le 17 février 2005 à 10:53:39
Citer
ceci dit, dans la serie "tâche"... le "Hébergement de votre site chez notre provider phpnet.fr"... c'est tout sauf pro...  :rolleyes:
Lu,

Je pense que tu peux formuler tes remarques par MP afin de ne pas faire que du HS ;)

Pour ma part, je ne recois pas non plus les mails envoyé d'une adresse Phpnet sur un compte Phpnet.

Quelqu'un a ouvert un ticket?

++

Portekoi
Titre: Mail()
Posté par: encorela le 17 février 2005 à 17:54:47
Salut,

j'ai le meme probleme. j'ai ouvert un ticket support la dessus. On m'a repondu que j'étais le seul utilisateur à avoir ce soucis, je vois qu'il n'en ai rien, mais pour autant on ne m'a pas donné de solution.

A suivre
Vincent
Titre: Mail()
Posté par: Ice le 17 février 2005 à 18:02:48
Encore 1 mail qui est passé à la trappe. (donc au moins 3 en 2 jours) :(
Titre: Mail()
Posté par: diaoul le 17 février 2005 à 18:10:13
ça passe, mais lentement...
1 h 05 d'un compte phpnet  à un autre...
lié au spamming en cours??
quel spamming?
je sais pas , j'ai rêvé...
Titre: Mail()
Posté par: photostereo le 17 février 2005 à 23:53:06
Oui, moi aussi j'ai des pb avec la fonction mail(), et depuis longtemps.
Il y a des mails qui n'arrivent pas. Heureusement que je fais des logs !
J'avais écrit la semaine dernière un post sur la question, mais il a été effacé,
dirait-on.

mail() = Problème politiquement très incorrect semble-t'il sur phpnet ...

Il faut dire qu'avant de s'abonner, toute personne un peu sensée épluche le forum,
et des mails qui se perdent, ce n'est pas du meilleur effet.  Un peu comme un banquier
qui ne saurait pas faire une addition ...
Titre: Mail()
Posté par: philipppe le 18 février 2005 à 00:52:14
Citer
Un peu comme un banquier
qui ne saurait pas faire une addition ...
Et oui, c'est ca faire confiance à phpnet... :rolleyes:  
Titre: Mail()
Posté par: photostereo le 18 février 2005 à 13:54:40
Citer
Les destinataires hors phpnet, ne pose pas de problème. !

Si !!!

Sur mon site,  on peut me contacter via un formulaire. Celui-ci m'envoie un message, et envoie un accusé de réception à mon visiteur.  
Après avoir fait qq tests avec mon adresse e-mail chez Free pour me faire passer comme visiteur, je constate que soit les deux messages sont envoyés et reçus dans les 5 minutes, soit ils sont tous  les deux perdus à jamais.
Titre: Mail()
Posté par: thibaud le 18 février 2005 à 15:07:30
le probleme de perte aleatoire de mail via mail() de php est fixé.

Tous les mails arrivent a present.
 
Titre: Mail()
Posté par: Portekoi le 18 février 2005 à 15:14:08
Merci Thibaud mais... ch'tite question : Ceux qui sont perdus... le sont définitivement?

Je pense que oui mais je demande toujour :)

Bye et Merci

Portekoi
Titre: Mail()
Posté par: maverick78 le 18 février 2005 à 16:52:42
oups rien dit enfait ^_^
Titre: Mail()
Posté par: maverick78 le 18 février 2005 à 21:20:06
que fais tu encore ici alors si tu es parti? tu tentes de rammener les brebis galeuses sous ta protection?
Titre: Mail()
Posté par: philipppe le 18 février 2005 à 21:32:52
Citer
que fais tu encore ici alors si tu es parti?
Effectivement, si cela peut éviter à d'autres de faire la même erreur....
Titre: Mail()
Posté par: photostereo le 18 février 2005 à 22:31:40
Merci pour la correction du bogue.
Maintenant, on va tester la chose !
Titre: Mail()
Posté par: photostereo le 18 février 2005 à 23:26:45
Premier mail envoyé : perdu.
Les tentatives suivantes (Une toutes les 2 minutes environ) : OK
Donc, ça marche (mal) comme avant.
C'est curieux c'est toujours le premier mail ou plutôt la première exécution du script php qui échoue.

A Suivre ...
Titre: Mail()
Posté par: diaoul le 19 février 2005 à 01:32:28
à propos de la fonction mail, comment se fait-il que plusieurs scripts qui ne marchaient pas il y quelques jours, mais Ice l'avait aussi remarqué :
http://www.phpnet.org/forum/index.php?show...dpost&p=8427530 (http://www.phpnet.org/forum/index.php?showtopic=7085&view=findpost&p=8427530)
remarchent maintenant sans y avoir touché?
le message était à chaque fois :
fonction mail() sender not in php.ini or header from missing (ou à peu près)...
comment une fonction peut-elle plus ou moins marcher?
merci de m'éclairer :blink:
Titre: Mail()
Posté par: Samiby le 19 février 2005 à 10:45:43
Thibaud a fait des modifications nécessaires pour que ça fonctionne ;) . Je pense que c'était dû à des problèmes de structure (un serveur d'envoi ou de réception de mails tombé en panne alors qu'il y en a plusieurs, ...)
Titre: Mail()
Posté par: diaoul le 19 février 2005 à 15:52:45
peut-être, mais je me serais attendu à un autre message d'erreur,non?  
Titre: Mail()
Posté par: wimbo le 21 février 2005 à 02:53:37
salut à tous

aujourdhui lundi 21 février à 2h54

ca plante toujours, la fonction mail() marche très bien vers free, noos, ...
mais pas vers phpnet,....

ou alors 1mail sur 5...

c'est pas top cool....
c'est pas tant le problème en lui même qui est facheux, car les problèmes techniques sont preque inhérant aux machines, mais le fait de le savoir

j'aimerais bien savoir quand le serveur pête un cable, histoire de rerouter mon mail()


merci d'avance
bonne continuation