Auteur Sujet: A L'aide !  (Lu 1481 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne alex6891

  • Débutant
  • *
  • Messages: 35
A L'aide !
« le: 01 juillet 2003 à 13:39:46 »
Récemment, j'ai modifié l'intégralité des fichiers de mon site internet. En les mettant à jour par le ftp, j'ai malencontreusement telechargé sur le web tous les fichiers du forum ibf-french (les anciens ont donc été écrasés).
Maintenant, lorsque je veux accèder au forum, j'ai tout un tas d'erreurs :

Warning: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) in /home/users/alex6891/www/forum/sources/Drivers/mySQL.php on line 64

Warning: MySQL Connection Failed: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) in /home/users/alex6891/www/forum/sources/Drivers/mySQL.php on line 64

Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /home/users/alex6891/www/forum/sources/Drivers/mySQL.php on line 67
ERROR: Cannot find database
Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/users/alex6891/www/forum/sources/Drivers/mySQL.php on line 100

puis l'erreur renvoyée :

mySQL query error: SELECT mod.mid as is_mod, m.id, m.name, m.mgroup, m.password, m.email, m.allow_post, m.view_sigs, m.view_avs, m.view_pop, m.view_img, m.auto_track,
m.mod_posts, m.language, m.skin, m.new_msg, m.show_popup, m.msg_total, m.time_offset, m.posts, m.joined, m.last_post,
m.last_visit, m.last_activity, m.dst_in_use, m.view_prefs, g.*
FROM ibf_members m
LEFT JOIN ibf_groups g ON (g.g_id=m.mgroup)
LEFT JOIN ibf_moderators mod ON (mod.member_id=m.id OR mod.group_id=m.mgroup )
WHERE m.id='1'

mySQL error: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
mySQL error code: 2002
Date: Tuesday 01st of July 2003 01:29:23 PM






Voilà ce que ça affiche lorsque j'accède à la page index.php du forum en question. Comment faire pour que ça redevienne comme avant ?
Merci de m'aider car j'ai besoin du forum rapidement !!!

@++  
 
 

Hors ligne funrighd

  • Débutant
  • *
  • Messages: 99
    • http://www.rock-review.com
A L'aide !
« Réponse #1 le: 01 juillet 2003 à 14:03:24 »
Il est possible que les paramètres d'accès à ta base de données ne soient plus bons.
Pour régler ce pb, essaie de ré-éditer le fichier config_global.php à la racine du répertoire de ton forum.

Hors ligne youp3

  • Débutant
  • *
  • Messages: 24
A L'aide !
« Réponse #2 le: 01 juillet 2003 à 15:38:52 »
En effet, il ne faut JAMAIS écraser le fichier conf_global.php qui se trouve à la racine du forum.

Une sauvegarde de ce fichier est même conseillée. Dans ton cas, comme on te le dit dans le message précédent, il faut que tu l'édites pour mettre les bonnes informations de connexion à la base de données.
« Modifié: 01 juillet 2003 à 15:39:32 par youp3 »

Hors ligne alex6891

  • Débutant
  • *
  • Messages: 35
A L'aide !
« Réponse #3 le: 01 juillet 2003 à 18:58:02 »
Oui mais voilà j'ai deux fichier identiques : conf_global.php, conf_global.php.ok.php sur mon ordi et trois sur le web : les même avec conf_global-back.php en plus !!!

Voilà le code de conf_global.php :

<?php
$INFO['sig_allow_ibc']         =   '1';
$INFO['show_user_posted']         =   '1';
$INFO['avatar_ext']         =   'gif|jpeg|jpg|swf|png';
$INFO['avatar_url']         =   '1';
$INFO['avup_size_max']         =   '20';
$INFO['avatars_on']         =   '1';
$INFO['avatar_dims']         =   '64x64';
$INFO['avatar_def']         =   '64x64';
$INFO['email_in']         =   '';
$INFO['email_out']         =   '';
$INFO['allow_images']         =   '1';
$INFO['max_emos']         =   '20';
$INFO['allow_creator_vote']         =   '1';
$INFO['allow_dynamic_img']         =   '0';
$INFO['allow_flash']         =   '1';
$INFO['allow_online_list']         =   '1';
$INFO['allow_skins']         =   '1';
$INFO['ban_ip']         =   '';
$INFO['ban_email']         =   '';
$INFO['ban_names']         =   '';
$INFO['board_start']         =   '1020214590';
$INFO['news_forum_id']         =   '1';
$INFO['index_news_link']         =   '1';
$INFO['allow_dup_email']         =   '1';
$INFO['admin_group']         =   '4';
$INFO['auth_group']         =   '1';
$INFO['member_group']         =   '3';
$INFO['guest_group']         =   '2';
$INFO['boardname']         =   'IBForums';
$INFO['board_desc']         =   'Website forums';
$INFO['board_name']         =   'IBForums';
$INFO['php_ext']         =   'php';
$INFO['board_url']         =   '';
$INFO['match_browser']         =   '0';
$INFO['clock_long']         =   '%A %d %B %Y, %H:%M';
$INFO['clock_short']         =   '%d %B %Y - %H:%M ';
$INFO['clock_joined']         =   '%d-%B %y';
$INFO['load_limit']         =   '';
$INFO['cookie_domain']         =   '';
$INFO['cookie_id']         =   '';
$INFO['cookie_path']         =   '';
$INFO['email_header']         =   'Cet email a été généré via IBForums';
$INFO['email_footer']         =   '';
$INFO['show_active']         =   '1';
$INFO['show_birthdays']         =   '1';
$INFO['show_totals']         =   '1';
$INFO['sql_driver']         =   'mySQL';
$INFO['sql_host']         =   'localhost';
$INFO['sql_database']      =   '';
$INFO['sql_pass']         =   '';
$INFO['sql_port']         =   '';
$INFO['sql_tbl_prefix']         =   'ibf_';
$INFO['sql_user']         =   'root';
$INFO['display_max_posts']         =   '15';
$INFO['display_max_topics']         =   '15';
$INFO['emo_per_row']         =   '3';
$INFO['etfilter_punct']         =   '0';
$INFO['etfilter_shout']         =   '0';
$INFO['flood_control']         =   '30';
$INFO['force_login']         =   '0';
$INFO['show_img_upload']         =   '1';
$INFO['home_name']         =   'ibforums.com';
$INFO['home_url']         =   'http://localhost';
$INFO['hot_topic']         =   '15';
$INFO['html_dir']         =   '';
$INFO['base_dir']         =   '';
$INFO['html_url']         =   '';
$INFO['upload_dir']         =   '';
$INFO['upload_url']         =   '';
$INFO['img_ext']         =   'gif|jpeg|jpg|png';
$INFO['max_h_flash']         =   '200';
$INFO['max_images']         =   '10';
$INFO['max_post_length']         =   '1000';
$INFO['max_w_flash']         =   '200';
$INFO['max_messages']         =   '50';
$INFO['pre_moved']         =   'Déplacé: ';
$INFO['pre_pinned']         =   'Epinglé: ';
$INFO['pre_polls']         =   'Sondage: ';
$INFO['session_expiration']         =   '3600';
$INFO['reg_auth_type']         =   '0';
$INFO['time_offset']         =   '0';
$INFO['new_reg_notify']         =   '0';
$INFO['use_mail_form']         =   '1';
$INFO['msg_allow_code']         =   '1';
$INFO['msg_allow_html']         =   '0';
$INFO['allow_search']         =   '1';
$INFO['print_headers']         =   '1';
$INFO['nocache']         =   '1';
$INFO['debug_level']         =   '1';
$INFO['forum_skin_1']         =   '';
$INFO['forum_skin_8']         =   '';
$INFO['board_offline']         =   '0';
$INFO['offline_msg']         =   '';
$INFO['no_reg']         =   '0';
$INFO['max_sig_length']         =   '50000';
$INFO['sig_allow_html']         =   '0';
$INFO['max_location_length']         =   '50000';
$INFO['max_interest_length']         =   '50000';
$INFO['post_titlechange']         =   '50000';
$INFO['ipshosting_credit'] = 1;

?>

merci de m'éclaircir sur ce qu'il faut modifier pour que ça fonctionne à nouveau !

Hors ligne maverick78

  • VIP
  • *****
  • Messages: 2 601
    • http://www.clan-ck.com
A L'aide !
« Réponse #4 le: 01 juillet 2003 à 19:30:57 »
$INFO['sql_host'] = 'localhost';
$INFO['sql_database'] = '';
$INFO['sql_pass'] = '';
$INFO['sql_port'] = '';
$INFO['sql_tbl_prefix'] = 'ibf_';
$INFO['sql_user'] = 'root';
La force est dans la céréale
Clan cereal-killer : http://www.clan-ck.com

Ne te demande pas ce que ton pays peut faire pour toi mais plutôt ce que tu peux faire pour ton pays...(JF Kennedy)

Hors ligne alex6891

  • Débutant
  • *
  • Messages: 35
A L'aide !
« Réponse #5 le: 02 juillet 2003 à 08:20:02 »
ok merci j'ai résolu le problème. Un fichier conf_global-back.php s'était crée et en le renommant en conf_global.php tout est rentré dans l'ordre. Encore merci 1000 fois !  :P