Auteur Sujet: Problème Compilation Php4.3.1 Sous Mandrake9.1  (Lu 2006 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne DarkSilver

  • Débutant
  • *
  • Messages: 60
    • http://www.crossrocks.com
Problème Compilation Php4.3.1 Sous Mandrake9.1
« le: 17 avril 2003 à 22:14:07 »
Je veux donc compiler php4.3.1 et apache 1.3.27 avec mes propres param.. enfin, faire ça proprement

l'install d'aapche, se passe sans problème...

pr contre pour php, j'ai tenté tous les différents configure que j'ai trouvé sur le net, ça marche
mais ensuite, quand je fais "make", je tombe sur cette erreur :
gcc: sapi/cli/php_cli.o: No such file or directory
gcc: sapi/cli/getopt.o: No such file or directory
make: *** [sapi/cli/php] Erreur 1

quelqu'un peut m'aider? car je suis aller dans ce répertoire et il y a les 2 fichiers en .c et .lo, mais pas en .o !!!

Merci

Hors ligne achil

  • Habitué
  • **
  • Messages: 178
Problème Compilation Php4.3.1 Sous Mandrake9.1
« Réponse #1 le: 17 avril 2003 à 22:24:36 »
les fichiers .o ou objet sont justement genere par gcc (c'est la compilation par gcc du fichier .c qui produit le .o) donc ta une merde quelque part.

BlueWhisper

  • Invité
Problème Compilation Php4.3.1 Sous Mandrake9.1
« Réponse #2 le: 17 avril 2003 à 22:34:34 »
essaie de taper:

make clean

Hors ligne DarkSilver

  • Débutant
  • *
  • Messages: 60
    • http://www.crossrocks.com
Problème Compilation Php4.3.1 Sous Mandrake9.1
« Réponse #3 le: 17 avril 2003 à 23:08:18 »
Citer
les fichiers .o ou objet sont justement genere par gcc (c'est la compilation par gcc du fichier .c qui produit le .o) donc ta une merde quelque part.
ouais, j'avais remarqué que j'avais une merde quelque part ;)

bon, j'ai suivi l'install de php.net, celle du README avec la tarball et celles de sites dde tutorials, etc..
mais : ça passe pas...

est-ce que quelqu'un sous mandrake peut m'indiquer précisémment la procédure ?
en gros, un truc genre ça  :http://www.php.net/manual/fr/install.apache.php mais qui marche sous Mandrake 9.1... merci !!!

D'ailleurs, quand j'étais sous Debian, j'arrivais même pas à compiler apache 1.3.27 ... (le configure faisait n'importe quoi !)
(donc comme je crois que phpnet est sous debian (non ?) , si thibaud voulait me dire comment il compile apache et php, je suis preneur !)

Merci

BlueWhisper

  • Invité
Problème Compilation Php4.3.1 Sous Mandrake9.1
« Réponse #4 le: 17 avril 2003 à 23:10:04 »
J'ai jamais eu de pb à compiler php, ni mysql, ni apache... (tu es sûr d'avoir toutes les librairies nécessaires?)

Hors ligne Bouki

  • Habitué
  • **
  • Messages: 244
    • http://www.scripetudes.net
Problème Compilation Php4.3.1 Sous Mandrake9.1
« Réponse #5 le: 18 avril 2003 à 00:27:00 »
j'ai installé la dernière version d'apache (2.xxx) de php (4.xxx) & de mysql (4.xxx) sous linux mandrake 9 & redhat 8 sans pbs.
désinstalle tout et réésaye de compil
Bouki
oO .:: [ Mage développeur Bouki ] ::. Oo